Bantam D7 running badly help needed

Classic Bike Forum's very own Bantam Guru dispenses expert advice on all things Bantam related.
User avatar
Iand
Posts: 755
Joined: Mon Feb 23, 2009 5:43 pm

Bantam D7 running badly help needed

Unread post by Iand » Sat Dec 31, 2011 6:21 pm

Afternoon I got my D3 95% finished now and couldn't resist a test run. Got it fired alright and it'll just about idle but as soon as I use the throttle it bogs down, it worse in 1st gear then the others, the clutch seems fine gear changes are great but the throttle has little or no effect. I tried playing around with the position of the needle and believe I have it in the correct position, 2nd from top, there are 4 positions and it seems to run best in this one.

Any ideas? It's a 375 Amal monobloc no idea what the jets are as I've never taken it apart other than to check the state of the float, it seems clean in the float bowl and the float seems ok too.

Cheers
IanD
1960 lambretta Li125 sold; 2001 Honda CG125 sold; 2006 Yamaha FZ6 sold; 1980 Kawasaki Z500 sold; 1967 BSA Bantam D10; 2008 Aprilia Shiver sold; 2010 KTM Duke 690R; 1954 BSA Bantam; 1980ish Kawasaki Z200

Buckinghamshire, UK

User avatar
Greenbat
Posts: 2748
Joined: Tue Feb 17, 2009 11:25 pm

Re: Bantam D7 running badly help needed

Unread post by Greenbat » Sat Dec 31, 2011 7:16 pm

Check the jets, could be a too big one somewhere.

User avatar
Iand
Posts: 755
Joined: Mon Feb 23, 2009 5:43 pm

Re: Bantam D7 running badly help needed

Unread post by Iand » Sat Dec 31, 2011 7:17 pm

Greenbat wrote:Check the jets, could be a too big one somewhere.


Yeah that's the next step, didn't have time to strip it down this afternoon I'll try to pop over tomorrow and pull it off, I presume the jet sizes are stamped on them somewhere??
1960 lambretta Li125 sold; 2001 Honda CG125 sold; 2006 Yamaha FZ6 sold; 1980 Kawasaki Z500 sold; 1967 BSA Bantam D10; 2008 Aprilia Shiver sold; 2010 KTM Duke 690R; 1954 BSA Bantam; 1980ish Kawasaki Z200

Buckinghamshire, UK

The Mighty Gusset

Re: Bantam D7 running badly help needed

Unread post by The Mighty Gusset » Sat Dec 31, 2011 7:55 pm

If it's bogging down as you open the throttle and it comes off idle I'd suspect a blocked main jet.
Of course, as those of us who frequent this forum are well aware, AMAL carbs are completely worn out after less than 1000 miles, so you need to fit a nice Mikuni.
Preferably one that's bolted to a nice reliable Honda engine.
HTH !

User avatar
Iand
Posts: 755
Joined: Mon Feb 23, 2009 5:43 pm

Re: Bantam D7 running badly help needed

Unread post by Iand » Sat Dec 31, 2011 8:17 pm

Just checked the shed and have a spare carb with all the correct jets in for my D7, it was fitted to my D3 150cc engine using a short spacer tube and has a thread on the other end to accept a pancake type air filter as opposed to the earlier style air filter on the carb I'm using at the moment. Strange!!

I'll try to get some time to try it out tomorrow or Monday before going back to work.
1960 lambretta Li125 sold; 2001 Honda CG125 sold; 2006 Yamaha FZ6 sold; 1980 Kawasaki Z500 sold; 1967 BSA Bantam D10; 2008 Aprilia Shiver sold; 2010 KTM Duke 690R; 1954 BSA Bantam; 1980ish Kawasaki Z200

Buckinghamshire, UK

User avatar
Iand
Posts: 755
Joined: Mon Feb 23, 2009 5:43 pm

Re: Bantam D7 running badly help needed

Unread post by Iand » Sat Dec 31, 2011 8:19 pm

The Mighty Gusset wrote:If it's bogging down as you open the throttle and it comes off idle I'd suspect a blocked main jet.
Of course, as those of us who frequent this forum are well aware, AMAL carbs are completely worn out after less than 1000 miles, so you need to fit a nice Mikuni.
Preferably one that's bolted to a nice reliable Honda engine.
HTH !


Yeah yeah but then I might aswell bolt that Honda engine into a Honda frame with Honda suspension brakes etc BUT THAT'S NOT THE POINT IS IT GUS!!
1960 lambretta Li125 sold; 2001 Honda CG125 sold; 2006 Yamaha FZ6 sold; 1980 Kawasaki Z500 sold; 1967 BSA Bantam D10; 2008 Aprilia Shiver sold; 2010 KTM Duke 690R; 1954 BSA Bantam; 1980ish Kawasaki Z200

Buckinghamshire, UK

User avatar
Hooli
Posts: 10183
Joined: Thu Feb 19, 2009 11:52 pm
Location: Doncaster

Re: Bantam D7 running badly help needed

Unread post by Hooli » Sat Dec 31, 2011 9:03 pm

The Mighty Gusset wrote:If it's bogging down as you open the throttle and it comes off idle I'd suspect a blocked main jet.
Of course, as those of us who frequent this forum are well aware, AMAL carbs are completely worn out after less than 1000 miles, so you need to fit a nice Mikuni.
Preferably one that's bolted to a nice reliable Honda engine.
HTH !


:lol: :lol: Is that all explained in your book 'Ruining Classic Bikes' Gus?
Classics ain't built in Metric

Post Reply